澳门皇冠金沙网站-澳门皇冠844网站

热门关键词: 澳门皇冠金沙网站,澳门皇冠844网站

刷OpenWRT标准版固件后安装LuCI的方法,如何刷OP

 

option proto "static"

澳门皇冠844网站 1

 

第4步、安装WIFDOG功能

 澳门皇冠844网站 2

 

7.输入“ping 8.8.8.8”,如果Ping通,表示已经成功接入互联网,按Ctrl C可停止Ping操作;

5.2  命令行方式安装软件 

opkg remove xxxx.ipk

通过以上步骤操作,您的路由器已经成功刷成OPENWRT系统,并且有WIFIDOG功能了.

(4)重启。

cat etc/config/network

5.ssh登录路由器的Linux终端;

 此外还可以使用 putty 来登录,Putty 是一个免费的、Windows 32 平台下的 telnet、 rlogin 和 ssh 客户端,但是功 能丝毫不逊色于商业的 telnet 类工具。

3.修改“config interface 'wan'”项目为如下:

telnet 192.168.1.1

(3)  在 winSCP 的文本编辑界面中,加入相关网络设置内容。

3.输入“opkg install luci-i18n-chinese_trunk svn9663-1_ar71xx.ipk”,安装LuCY简体中文语言;最后显示“Configuring luci-i18n-chinese.”;

option dns "202.102.224.68"

(3)在 nwan 的设置界面。外网接口,添加你的 wan 口进去。(输入 wan 口名称,点击添加)

11.在Design下下接框中选择“Bootstrap”,把主题改成Bootstrap;

澳门皇冠844网站,option _orig_ifname "eth0"

 ckages/

 

4.保存,再次打开network文件,确认修改成功;

用以上的各种软件安装方法均可轻松实现 luci 的汉化。官方提供了名为 luci-i18n-chinese 的汉化包。 安装成功后, 在 system—–system—–language and style 的 language 选项中选 择 chinese,save and apply。 刷新页面之后,即变成了中文界面

 

第2步、修改network配置连上互联网

 分别进入每个接口,设置网络连接方式。单线多拨,我们通常是是设置 pppoe 的 用户名和密码。如果你的网络 环境允许 5 拨,那么你的每个接口便分别波上号,并分别获取 IP 地址了。

 

刷好的openwrt标准版 没有web管理界面(LuCI),需要安装才可以管理

(2)在 cmd 下面进入该目录,输入命令 Physdiskwrite.exe –u backfire.img 进行写盘。 其中-u  参数为目标磁盘大于 800M 时需要附加的。

2.输入“opkg install luci_trunk svn9663-1_ar71xx.ipk”,安装LuCY主体,先开始自动下载各种关联库,下载完会自动安装配置,最后显示“Configuring luci.”;

option gateway "192.168.100.1"

5.1.2  通过网址下载安装

4.按Ctrl S保存,或直接点保存图标,会再次出现提示窗口,按“否”按钮,显示上传提示;

option _orig_bridge "false"

服务器。

 

opkg install wifidog //安装wifidog

 澳门皇冠844网站 3

option _orig_ifname 'eth1'

二.刷写固件:

 澳门皇冠844网站 4

 

等待一会,提示几行“,radio0, is disabled”等状态信息就表示重启完毕;

对于 Openwrt 来说使用上面任何一个写盘工具都没有多大影响,但是对于某些软路由来说用 win32diskimager 写 入的时候会导致无法启动等情况。建议大家使用 physdiskwrite 写盘。

9.点开Language and Style选项页;

/etc/init.d/uhttpd enable    //启用

需要注意的是 N-WAN 是基于 IP 的负责均衡,而不是基于 session。同时 N-WAN 的并发功能有限。

 

6.输入

openwrt 的 web 管理界面

 

本文由http://www.wifidog.pro/2015/02/10/openwrt实现wifidog.html整理编辑,转载请注明出处

isfuse=`lsmod | grep fuse`

 

/etc/init.d/uhttpd start        //启动

win32diskimager 写盘

1.打开PuTTY,点树状列表中的“Session”项;

3.修改“config interface ,wan,”项目为如下:

opkg update

config interface 'wan'

在OpenWr官方网站() 页面,找到自己路由器对应型号的固件.

mount /dev/sdb1  /mnt/test,以便于系统启动之后进行自动挂载。(直 接编辑/etc/rc.local 文件也可)

option proto 'pppoe'

opkg install luci    //安装管理界面

IMG 写盘工具通常使用 physdiskwrite 或者 Win32DiskImager 下载地 址: Physdiskwrite: 0.5.2.zip Win32DiskImager:

 

一.下载固件:

fi

 

/etc/init.d/network restart

fi

 

option netmask "255.255.255.0"

web 管理界面设置网络接口

 

第3步、安装Web管理界面LuCY;

DHCP 方式:

 

第1步、修改Root密码

config ’interface’ ’WAN’ option ’ifname’ ’eth1′ option ’proto’ ’dhcp’

5.输入“/etc/init.d/uhttpd enable”回车,打开uhttpd服务;

config interface "wan"

(2) 在软件管理界面点击,Update package lists  更新软件包列表

3.再一次输入root用户的密码,,输入过程没显示字符或掩码,输入完毕,回车,出现Password for root changed by root提示,表示更改root用户密码成功,为了安全,OpenWRT会把路由器的Telnet服务关闭,以后只能通过ssh协议和root用户密码登录路由器的Linux终端。

opkg install luci-i18n-chinese  //安装中文语言包

opkg install block-mount fdisk  usbutils

1.用WinSCP登陆路由器;

2.进入路由器的/etc/config目录,双击打开network文件;

【为了输入方便,可以将 Physdiskwrite.exe 改名为 pdw.exe 之类,命令输入 pd w.exe  –u backfire.img 即 可】

 

三. 安装管理界面和WIFIDOG功能.

2.1  写盘工具  

 

OpenWRT会把路由器的Telnet服务关闭,以后只能通过ssh协议和root用户密码登录路由器的Linux终端。

5.1 web 界面安装软件  

lists_dir ext /var/opkg-lists

option ifname "eth0.2"

N-WAN 是由 openwrt 中文论坛的飞翔的天空开发的。N-WAN 可单线多拨、多线多拨进行叠加和负载平衡,并附 带指定出口功能。使用比较简单。在这里向飞翔的天空表示感谢。

#src/gz packages

输入passwd root 然后修改Root密码

4.2.2  下载后手动上传安装

10.在Language下接框中选择“chinese”,把语言改成中文;

option ipaddr "192.168.100.86"

3.1.3 SSH 登录  

 

1.用WinSCP登陆路由器;

3.1.2  远程控制台(telnet/SSH)  

 

用一根网线将路由器的Lan口和你电脑相连,电脑上设置为DHCP模式进入路由器管理界面,,然后进入固件更新,选择下载的文件,然后更新。等待一段时间,然后重启路由。

(3)点击 submit,便进入了接口编辑页面。

 

opkg update

 命令与本地控制台相同。Passwd root

注,以上可以使用Windows命令Telnet操作。

出现Password for root changed by root提示,表示更改root用户密码成功,

5.3 trunk 版 luci 界面安装 

 

(1) secureCRT 登录,登录协议选择为 SSH2

  修改ipk包的软件源

Openwrt 可以通过 LAN 或者 WAN,对系统进行管理控制。支持 telnet 及 SSH 登录。 注意:SSH 登录必须先设置 root 帐号的密码(系统默认密码为空)

 

参考图:

 

(1)将网站上的 ipk 包下载到本机保存。

1.在Linux终端中,输入“passwd root”,提示Changing password for root New passoword:的提示;

澳门皇冠844网站 5

1.下载*.ipk插件包;

分享: 

vim etc/config/network

mount  -t vfat  -o iocharset=utf8,rw,sync,umask=0000,dmask=0000,fmask=0000  /dev/$device

 

3.1 openwrt 的控制台  

option ifname 'eth1'

(1)将 Physdiskwrite.exe 和镜像文件放在同一目录里

dest plugin_root /plugin_root

 (3)成功之后,会提示 Install ’****.ipk’: OK

 

 

(4)  保存,保存过程中会提示输入密码。

13.按下“Logout”选项退出,即出现中文Bootstrap的登录界面。

通过 SSH 方式修改 network 配置文件,并不是很方便直观。我们可以直接利用 winSCP 登录 openwrt 来进行修改

 

win32diskimager 是一个图形化的磁盘写入工具。Win7 下面建议使用“以管理员身 份运行”

 

opkg install mount-utils

option overlay_root /overlay

3.1.4 winSCP 的使用  

3.在Connection type中选择“Telnet”,按下Open按钮,进入路由器的Linux终端,出现OpenWRT欢迎界面和[email protected]:~#提示符;

10-mount 文件也可以到这里下载:  

  编辑文件:

(1)首先,设置 wan 口,使 openwrt 正确连上网络。(设置见四  基本网络设置)

 

因为现在网络接口只有一个 lan 口,wan 口尚未设置。 主要有两个方法进行设置:

 

if [ `basename $blkdev` != "block" ]; then

 

(2) 在接下来的回话选项中,协议选择为 SSH2,输入默认的 ip 地址(192.168.1. 1) 然后一直下一步。

2.用WinSCP上传a.ipk、b.ipk、c.ipk到/tmp下;

四 基本网络设置  

4.输入“opkg install luci-theme-bootstrap_trunk svn9663-1_ar71xx.ipk”,安装LuCY主题,最后显示“Configuring luci-theme-bootstrap.”;

case ”$ACTION” in

 

2.2 Physdiskwrite 写盘

 

4.3  通过 winSCP 设置网络接口

option username '你的宽带账号'

 澳门皇冠844网站 6

一、与OpenWRT的路由器联机 用网线连接电脑的LAN口和路由器的LAN口,然后操作如下: 1.打开PuTTY,点树状...

服务器。

刷OpenWRT标准版固件后安装LuCI的方法

VI  命令下无须输入  ’  引号

  显示文件:

Openwrt 官方提供 backfire 和 trunk 两个不通的编译版本。 区别在于,backfire 相对更加正式而稳定,而 trunk 则相对为更新的测试版本

五、其它要点

6.2 N-WAN 的设置  

3.用PuTTY执行:  

 特别注意:由于 NWAN 主要是针对路由器版本的 openwrt 开发,而非 X86。因此 在创建虚拟多 WAN 口的时候, 一定要注意 “从哪个 WAN 接口 生成虚拟 wan”。比如我们有 4 张网卡,可以设置 4 个 不同的 wan 口。为了能够正常 的使用单线虚拟多拨。四 个 wan 口的名称,应分别为 wan,wan100,wan200,wan30 0。否则 nwan 无法正常识别, 同时设置为其他名称是比 如 W1 之类,创建多 wan 口的设置页面里面也不能够提供名 为 W1 的 wan 接口选项。

  离线批量ipk安装方法

isvfat=`fdisk -l | grep $device | grep FAT`

一、与OpenWRT的路由器联机

(4)  重启之后,USB 移动硬盘、U 盘均可以自动挂载。同时在将会在  系统选项里面增加一个“挂载点”的选 项。可以在“挂载点”选项里面查看挂载情况

四、安装Web管理界面LuCY;

 澳门皇冠844网站 7

/etc/opkg.conf文件记录着软件源,src/gz Packages后面地址就是软件源了,opk.conf文件代码如下:

/etc/init.d/uhttpd star

 

 4.1

 

7.1  自动挂载 USB 移动硬盘,U 盘 

8.进入LuCY界面的System选项页;

(2)  在 winSCP 中直接打开/etc/config 目录,双击打开 network 文件

 

现在虽然能打开 openwrt 的 web 管理界面,或者远程登录控制台。但是,这个时 候还不能透过 openwrt 上网。

 

 5.1.1  安装官方源提供的软件

 

双击 10mount 编辑,输入以下内容:

12.按下“Save & Apply”,保存并应用;

(3) 此时,我们在网络—-接口 页面可以看到新生产的虚拟机 wan 口

 

 Firewall setting 选项卡里面,选择防火墙区域,设置为 WAN。(如果不设置防火墙 区域,将无法上网)

7.在提示符后输入“/etc/init.d/network restart”,等待一会,提示几行“'radio0' is disabled”等状态信息就表示重启完毕;

(7)最后,挂载成功之后,打开“系统—启动项”,在本地启动脚本里面加入一 行

二、修改Root密码

同时,每个版本分别提供以不同磁盘格式下面的镜像。分别包括 ext2/ext4,jffs2,squashfs 三种格式。 为了方便,在这里我们选择的是 ext2/ext4 格式的镜像文件。

6.输入“/etc/init.d/uhttpd start”回车,让uhttpd自启动;

6.2 N-WAN 的设置

2.输入root用户的密码,输入过程没显示字符或掩码,输入完毕,回车,出现Retype password:的提示;

(4) 输入 mkdir  /mnt/test ,其中 test 为你需要设置的挂点名称,可自己任 意设置。

7.在电脑端的浏览器中输入“192.168.1.1”,可访问路由器就表示LuCY安装成功;

N-WAN 下载地址:

1.在打开PuTTY显示的路由器Linux终端中,输入“opkg update”,开始下载Packages.gz并更新;

 Physdiskwrite 是基于 DOS 的写盘工具,需要在 CMD 下面进行操作。

  在第四部分第2、3、4步可以先下载好这三个ipk包,用WinSCP放到路由器的/tmp目录,再用“cd /tmp”命令进入/tmp目录执行,这样可以避免连接错误。

(1)在网络—-接口界面添加 WAN2,WAN3……等。(具体可以参见 4.1  web 管理界面设置网络接口),名字设定 无特殊限制,可根据自己爱好设置。注意设置好防火墙区域即可

 

4.4  各种上网方式的 network 设置

用网线连接电脑的LAN口和路由器的LAN口,然后操作如下:

 SecureCRT 是一款支持 SSH(SSH1 和 SSH2)的终端仿真程序,同时支持 Telnet 和 rl ogin 协议。SecureCRT 是一款

8.在提示符后输入“ping 8.8.8.8”,如果Ping通,表示已经成功接入互联网,按Ctrl C可停止Ping操作;

需要注意的是:官方编译的 openwrt backfire 10.03 RC5 版本里面的软件源地址设置错误。导致无法正常更新和安 装软件,需要我们手动修改。

 

esac

三、修改network配置连上互联网

Name of the new interface 设置接口名称—-(设为 WAN,或者 WAN1 之类)

  删除已安装的ipk:

# vfat & ntfs-3g check

dest root /                  

(1)通过 secureCRT 或 Putty 之类的 SSH 工具登陆 openwrt

opkg update

Openwrt 的 web 管理界面主要有 luci 和 X-wrt。目前应用得比较多的是 luci,最新 版本为 1.0。 本教程以 luci 界面为主。

2.进入路由器的/etc/config目录,双击打开network文件;

(4) 在 Available packages 中选择你需要的软件包,每个软件包后面均附有简单介 绍。点击安装即可。

5.再次打开network文件,确认修改成功;

(1)找到你所需要的软件 ipk 包的地址,如 NWAN:  ci1.0.ipk

option password '账号密码'

六 N-WAN 的安装和使用  

本文由澳门皇冠金沙网站发布于网络操作,转载请注明出处:刷OpenWRT标准版固件后安装LuCI的方法,如何刷OP